Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2025-67635

CVE-2025-67635: Jenkins has a Denial of service vulnerability in HTTP-based CLI

December 10, 2025 (updated January 22, 2026)

Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.

References

  • fluidattacks.com/blog/unauth-dos-in-jenkins-cli
  • github.com/advisories/GHSA-9p56-p6mw-w8qc
  • github.com/jenkinsci/jenkins
  • github.com/jenkinsci/jenkins/commit/efa1816322026f2b9235a27eee814bcc7ba0a764
  • nvd.nist.gov/vuln/detail/CVE-2025-67635
  • www.jenkins.io/security/advisory/2025-12-10/

Code Behaviors & Features

Detect and mitigate CVE-2025-67635 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.528.3, all versions starting from 2.529 before 2.541

Fixed versions

  • 2.541
  • 2.528.3

Solution

Upgrade to versions 2.528.3, 2.541 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-404: Improper Resource Shutdown or Release

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2025-67635.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.