Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2019-1003004

CVE-2019-1003004: Insufficient Session Expiration

January 22, 2019 (updated October 9, 2019)

An improper authorization vulnerability exists in Jenkins in core/src/main/java/hudson/security/AuthenticationProcessingFilter2.java that allows attackers to extend the duration of active HTTP sessions indefinitely even though the user account may have been deleted in the mean time.

References

  • www.securityfocus.com/bid/106680
  • jenkins.io/security/advisory/2019-01-16/
  • nvd.nist.gov/vuln/detail/CVE-2019-1003004

Code Behaviors & Features

Detect and mitigate CVE-2019-1003004 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.150.1 up to 2.159

Fixed versions

  • 2.160

Solution

Upgrade to version 2.160 or above.

Impact 7.2 HIGH

CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2019-1003004.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:13 +0000.