Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2019-1003003

CVE-2019-1003003: Insufficient Session Expiration

January 22, 2019 (updated October 9, 2019)

An improper authorization vulnerability exists in Jenkins in core/src/main/java/hudson/security/TokenBasedRememberMeServices2.java that allows attackers with Overall/RunScripts permission to craft Remember Me cookies that would never expire, allowing to persist access to temporarily compromised user accounts.

References

  • www.securityfocus.com/bid/106680
  • jenkins.io/security/advisory/2019-01-16/
  • nvd.nist.gov/vuln/detail/CVE-2019-1003003

Code Behaviors & Features

Detect and mitigate CVE-2019-1003003 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.150.1 up to 2.158

Fixed versions

  • 2.159

Solution

Upgrade to version 2.159 or above.

Impact 7.2 HIGH

CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2019-1003003.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:05 +0000.