Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2018-1999047

CVE-2018-1999047: Incorrect Authorization

August 23, 2018 (updated October 3, 2019)

An improper authorization vulnerability exists in Jenkins in UpdateCenter.java that allows attackers to cancel a Jenkins restart scheduled through the update center.

References

  • jenkins.io/security/advisory/2018-08-15/
  • nvd.nist.gov/vuln/detail/CVE-2018-1999047

Code Behaviors & Features

Detect and mitigate CVE-2018-1999047 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.121.2 up to 2.137

Fixed versions

  • 2.138

Solution

Upgrade to version 2.138 or above.

Impact 6.5 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2018-1999047.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:50 +0000.