Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2018-1999006

CVE-2018-1999006: Information Exposure

July 23, 2018 (updated May 8, 2019)

Sensitive information is leaked through Plugin.java that allows attackers to determine the date and time when a plugin HPI/JPI file was last extracted, which typically is the date of the most recent installation/upgrade.

References

  • jenkins.io/security/advisory/2018-07-18/
  • nvd.nist.gov/vuln/detail/CVE-2018-1999006

Code Behaviors & Features

Detect and mitigate CVE-2018-1999006 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.121.1 up to 2.132

Fixed versions

  • 2.133

Solution

Upgrade to version 2.133 or above.

Impact 4.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2018-1999006.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.