Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2018-1999004

CVE-2018-1999004: Incorrect Authorization

July 23, 2018 (updated October 3, 2019)

An Improper authorization vulnerability exists in Jenkins in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.

References

  • jenkins.io/security/advisory/2018-07-18/
  • nvd.nist.gov/vuln/detail/CVE-2018-1999004

Code Behaviors & Features

Detect and mitigate CVE-2018-1999004 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.121.1, all versions starting from 2.122 up to 2.132

Fixed versions

  • 2.121.2
  • 2.133

Solution

Upgrade to versions 2.121.2, 2.133 or above.

Impact 4.3 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2018-1999004.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.