Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2018-1000407

CVE-2018-1000407: Cross-site Scripting

January 9, 2019 (updated May 8, 2019)

A cross-site scripting vulnerability exists in Jenkins, in core/src/main/java/hudson/model/Api.java that allows attackers to specify URLs to Jenkins that result in rendering arbitrary attacker-controlled HTML by Jenkins.

References

  • www.securityfocus.com/bid/106532
  • jenkins.io/security/advisory/2018-10-10/
  • nvd.nist.gov/vuln/detail/CVE-2018-1000407

Code Behaviors & Features

Detect and mitigate CVE-2018-1000407 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.138.1 up to 2.145

Fixed versions

  • 2.146

Solution

Upgrade to version 2.146 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2018-1000407.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:07 +0000.