Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2017-2601

CVE-2017-2601: Cross-site Scripting

May 10, 2018 (updated October 9, 2019)

Jenkins is vulnerable to a persisted cross-site scripting in parameter names and descriptions. Users with the permission to configure jobs were able to inject JavaScript into parameter names and descriptions.

References

  • www.securityfocus.com/bid/95960
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2601
  • jenkins.io/security/advisory/2017-02-01/
  • nvd.nist.gov/vuln/detail/CVE-2017-2601

Code Behaviors & Features

Detect and mitigate CVE-2017-2601 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.32.2 before 2.44

Fixed versions

  • 2.44

Solution

Upgrade to version 2.44 or above.

Impact 5.4 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2017-2601.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:18 +0000.