Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2017-1000396

CVE-2017-1000396: Improper Certificate Validation

January 26, 2018 (updated May 8, 2019)

Jenkins bundled a version of the commons-httpclient library that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

References

  • jenkins.io/security/advisory/2017-10-11/
  • nvd.nist.gov/vuln/detail/CVE-2017-1000396

Code Behaviors & Features

Detect and mitigate CVE-2017-1000396 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions after 2.73.1 up to 2.83

Fixed versions

  • 2.86

Solution

Upgrade to version 2.86 or above.

Impact 5.9 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2017-1000396.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.