Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2015-1814

CVE-2015-1814: Jenkins allows for Privilege Escalation by Remote Authenticated Users

May 17, 2022 (updated October 31, 2025)

The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a “forced API token change” involving anonymous users.

References

  • access.redhat.com/errata/RHSA-2016:0070
  • bugzilla.redhat.com/show_bug.cgi?id=1205616
  • github.com/advisories/GHSA-3269-jqp5-v8c9
  • github.com/jenkinsci/jenkins
  • github.com/jenkinsci/jenkins/commit/57e78880cc035874bda916ef4d8d7fd7642af9db
  • nvd.nist.gov/vuln/detail/CVE-2015-1814
  • wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-03-23

Code Behaviors & Features

Detect and mitigate CVE-2015-1814 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.596.2, all versions starting from 1.597 before 1.606

Fixed versions

  • 1.606
  • 1.596.2

Solution

Upgrade to versions 1.596.2, 1.606 or above.

Impact 7.3 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-266: Incorrect Privilege Assignment

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2015-1814.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:06 +0000.