Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2015-1813

CVE-2015-1813: Jenkins allows Cross-Site Scripting (XSS)

May 17, 2022 (updated October 31, 2025)

Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1812.

References

  • access.redhat.com/errata/RHSA-2016:0070
  • bugzilla.redhat.com/show_bug.cgi?id=1205615
  • github.com/advisories/GHSA-9h85-v6xf-h26q
  • github.com/jenkinsci/jenkins
  • github.com/jenkinsci/jenkins/commit/feb2703adb0c121705e5c8e9ddf8f663b6481cbd
  • nvd.nist.gov/vuln/detail/CVE-2015-1813
  • wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-03-23

Code Behaviors & Features

Detect and mitigate CVE-2015-1813 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.596.2, all versions starting from 1.597 before 1.606

Fixed versions

  • 1.606
  • 1.596.2

Solution

Upgrade to versions 1.596.2, 1.606 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2015-1813.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:20 +0000.