Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2014-3681

CVE-2014-3681: Jenkins Cross-site Scripting vulnerability

May 14, 2022 (updated April 14, 2025)

Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

References

  • access.redhat.com/errata/RHBA-2014:1630
  • access.redhat.com/errata/RHSA-2016:0070
  • access.redhat.com/security/cve/CVE-2014-3681
  • bugzilla.redhat.com/show_bug.cgi?id=1147766
  • exchange.xforce.ibmcloud.com/vulnerabilities/96975
  • github.com/advisories/GHSA-cwh9-f8m6-6r63
  • nvd.nist.gov/vuln/detail/CVE-2014-3681
  • wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-10-01

Code Behaviors & Features

Detect and mitigate CVE-2014-3681 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.565.3, all versions starting from 1.566 before 1.583

Fixed versions

  • 1.583
  • 1.565.3

Solution

Upgrade to versions 1.565.3, 1.583 or above.

Impact 4.3 MEDIUM

AV:N/AC:M/Au:N/C:N/I:P/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2014-3681.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.