Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jenkins-ci.main/jenkins-core
  4. ›
  5. CVE-2011-4344

CVE-2011-4344: Jenkins allows Cross-Site Scripting (XSS)

May 17, 2022 (updated October 31, 2025)

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

References

  • github.com/advisories/GHSA-q3rp-555r-hh6r
  • github.com/jenkinsci/jenkins
  • github.com/jenkinsci/winstone/commit/410ed3001d51c689cf59085b7417466caa2ded7b.patch
  • nvd.nist.gov/vuln/detail/CVE-2011-4344
  • web.archive.org/web/20200229031004/https://www.securityfocus.com/bid/50786

Code Behaviors & Features

Detect and mitigate CVE-2011-4344 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.409.3, all versions starting from 1.410 before 1.438

Fixed versions

  • 1.409.3
  • 1.438

Solution

Upgrade to versions 1.409.3, 1.438 or above.

Impact 3.1 LOW

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jenkins-ci.main/jenkins-core/CVE-2011-4344.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:55 +0000.