Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.jboss.hal/hal-console
  4. ›
  5. GHSA-64gp-r758-8pfm

GHSA-64gp-r758-8pfm: Cross Site Scripting (XSS) vulnerability while uploading content to a new deployment

December 23, 2024 (updated October 31, 2025)

A vulnerability was found in the WildFly management console. A user may perform cross-site scripting in the deployment system. An attacker (or insider) may execute a malicious payload which could trigger an undesired behavior against the server.

References

  • github.com/advisories/GHSA-64gp-r758-8pfm
  • github.com/hal/console
  • github.com/hal/console/releases/tag/v3.7.7
  • github.com/hal/console/security/advisories/GHSA-64gp-r758-8pfm
  • issues.redhat.com/browse/WFLY-19969

Code Behaviors & Features

Detect and mitigate GHSA-64gp-r758-8pfm with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.7.7.Final

Fixed versions

  • 3.7.7.Final

Solution

Upgrade to version 3.7.7.Final or above.

Impact 7.3 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-1395: Dependency on Vulnerable Third-Party Component
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.jboss.hal/hal-console/GHSA-64gp-r758-8pfm.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:35 +0000.