Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.igniterealtime.openfire/distribution
  4. ›
  5. CVE-2018-11688

CVE-2018-11688: Cross-site Scripting

June 13, 2018 (updated June 20, 2019)

Ignite Realtime Openfire is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim’s Web browser within the security context of the hosting Website, once the URL is clicked. An attacker could use this vulnerability to steal the victim’s cookie-based authentication credentials.

References

  • www.securityfocus.com/archive/1/542060/100/0/threaded
  • nvd.nist.gov/vuln/detail/CVE-2018-11688

Code Behaviors & Features

Detect and mitigate CVE-2018-11688 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 3.7.1

Fixed versions

  • 4.3.0

Solution

Upgrade to version 4.3.0 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.igniterealtime.openfire/distribution/CVE-2018-11688.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.