Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.grails.plugins/fields
  4. ›
  5. CVE-2018-1000529

CVE-2018-1000529: Stored Cross Site Scripting in Grails Fields Plugin

October 19, 2018 (updated November 18, 2024)

Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in using the display tag that can result in XSS. This vulnerability has been fixed in version 2.2.8.

References

  • github.com/advisories/GHSA-q25j-gcmv-5qpp
  • github.com/grails-fields-plugin/grails-fields
  • github.com/grails-fields-plugin/grails-fields/issues/278
  • github.com/martinfrancois/CVE-2018-1000529
  • nvd.nist.gov/vuln/detail/CVE-2018-1000529

Code Behaviors & Features

Detect and mitigate CVE-2018-1000529 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.2.8

Fixed versions

  • 2.2.8

Solution

Upgrade to version 2.2.8 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.grails.plugins/fields/CVE-2018-1000529.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:33 +0000.