Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.geoserver/gs-wfs
  4. ›
  5. GHSA-68cf-j696-wvv9

GHSA-68cf-j696-wvv9: GeoServer vulnerable to SSRF in TestWfsPost for specific targets, e.g. PHP + Nginx

June 10, 2025

Missing checks allow for SSRF to specific targets using the TestWfsPost enpoint.

References

  • github.com/advisories/GHSA-68cf-j696-wvv9
  • github.com/geoserver/geoserver
  • github.com/geoserver/geoserver/security/advisories/GHSA-5gw5-jccf-6hxw
  • github.com/geoserver/geoserver/security/advisories/GHSA-68cf-j696-wvv9

Code Behaviors & Features

Detect and mitigate GHSA-68cf-j696-wvv9 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.0 before 2.24.4, all versions starting from 2.25.0 before 2.25.2

Fixed versions

  • 2.24.4
  • 2.25.2

Solution

Upgrade to versions 2.24.4, 2.25.2 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

maven/org.geoserver/gs-wfs/GHSA-68cf-j696-wvv9.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.