Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.elasticsearch/elasticsearch
  4. ›
  5. CVE-2024-37280

CVE-2024-37280: Elasticsearch StackOverflow vulnerability

June 13, 2024 (updated October 3, 2024)

A flaw was discovered in Elasticsearch, affecting document ingestion when an index template contains a dynamic field mapping of “passthrough” type. Under certain circumstances, ingesting documents in this index would cause a StackOverflow exception to be thrown and ultimately lead to a Denial of Service. Note that passthrough fields is an experimental feature.

References

  • discuss.elastic.co/t/elasticsearch-8-14-0-security-update-esa-2024-14/361007
  • github.com/advisories/GHSA-4q22-422g-m4pj
  • github.com/elastic/elasticsearch
  • nvd.nist.gov/vuln/detail/CVE-2024-37280

Code Behaviors & Features

Detect and mitigate CVE-2024-37280 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.13.1 before 8.14.0

Fixed versions

  • 8.14.0

Solution

Upgrade to version 8.14.0 or above.

Impact 4.9 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-122: Heap-based Buffer Overflow
  • CWE-787: Out-of-bounds Write

Source file

maven/org.elasticsearch/elasticsearch/CVE-2024-37280.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.