Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.elasticsearch/elasticsearch
  4. ›
  5. CVE-2023-31419

CVE-2023-31419: Elasticsearch vulnerable to stack overflow in the search API

October 26, 2023 (updated October 30, 2023)

A flaw was discovered in Elasticsearch, affecting the _search API that allowed a specially crafted query string to cause a Stack Overflow and ultimately a Denial of Service.

References

  • discuss.elastic.co/t/elasticsearch-8-9-1-7-17-13-security-update/343297
  • github.com/advisories/GHSA-qwrx-45xf-jjf7
  • nvd.nist.gov/vuln/detail/CVE-2023-31419
  • www.elastic.co/community/security

Code Behaviors & Features

Detect and mitigate CVE-2023-31419 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.0.0 before 7.17.13, all versions starting from 8.0.0 before 8.9.1

Fixed versions

  • 7.17.13
  • 8.9.1

Solution

Upgrade to versions 7.17.13, 8.9.1 or above.

Source file

maven/org.elasticsearch/elasticsearch/CVE-2023-31419.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.