Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.elasticsearch/elasticsearch
  4. ›
  5. CVE-2022-23708

CVE-2022-23708: Elasticsearch privilege escalation issue

March 4, 2022 (updated March 8, 2022)

A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.

References

  • discuss.elastic.co/t/elastic-stack-7-17-1-security-update/298447
  • github.com/advisories/GHSA-pgq6-ccqj-hpqr
  • nvd.nist.gov/vuln/detail/CVE-2022-23708

Code Behaviors & Features

Detect and mitigate CVE-2022-23708 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.16.0 before 7.17.1

Fixed versions

  • 7.17.1

Solution

Upgrade to version 7.17.1 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Source file

maven/org.elasticsearch/elasticsearch/CVE-2022-23708.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:27 +0000.