Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.elasticsearch/elasticsearch
  4. ›
  5. CVE-2021-22144

CVE-2021-22144: Uncontrolled Recursion

August 9, 2021 (updated August 31, 2021)

In Elasticsearch versions before 7.13.3 and 6.8.17 an uncontrolled recursion vulnerability that could lead to a denial of service attack was identified in the Elasticsearch Grok parser. A user with the ability to submit arbitrary queries to Elasticsearch could create a malicious Grok query that will crash the Elasticsearch node.

References

  • discuss.elastic.co/t/elasticsearch-7-13-3-and-6-8-17-security-update/278100
  • github.com/advisories/GHSA-3393-hvrj-w7v3
  • nvd.nist.gov/vuln/detail/CVE-2021-22144
  • security.netapp.com/advisory/ntap-20210827-0006/

Code Behaviors & Features

Detect and mitigate CVE-2021-22144 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.8.17, all versions after 7.0.0 before 7.13.3

Fixed versions

  • 6.8.17
  • 7.13.3

Solution

Upgrade to versions 6.8.17, 7.13.3 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

maven/org.elasticsearch/elasticsearch/CVE-2021-22144.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:22 +0000.