Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.elasticsearch/elasticsearch
  4. ›
  5. CVE-2020-7009

CVE-2020-7009: Improper Privilege Management

May 24, 2022 (updated June 23, 2022)

Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.

References

  • discuss.elastic.co/t/elastic-stack-6-8-8-and-7-6-2-security-update/225920
  • github.com/advisories/GHSA-gfv5-grx2-9jw2
  • nvd.nist.gov/vuln/detail/CVE-2020-7009
  • security.netapp.com/advisory/ntap-20200403-0004/
  • www.elastic.co/community/security/

Code Behaviors & Features

Detect and mitigate CVE-2020-7009 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 6.7.0 up to 6.8.7, all versions starting from 7.0.0 up to 7.6.1

Fixed versions

  • 6.8.8
  • 7.6.2

Solution

Upgrade to versions 6.8.8, 7.6.2 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

maven/org.elasticsearch/elasticsearch/CVE-2020-7009.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:46 +0000.