Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.dspace/dspace-api
  4. ›
  5. CVE-2025-53622

CVE-2025-53622: DSpace is vulnerable to Path Traversal attacks when importing packages using Simple Archive Format

July 15, 2025

A path traversal vulnerability is possible during the import of an archive (in Simple Archive Format), either from command-line (./dspace import command) or from the “Batch Import (Zip)” user interface feature. This vulnerability likely impacts all versions of DSpace 1.x <= 7.6.3, 8.0 <= 8.1, and 9.0.

An attacker may craft a malicious Simple Archive Format (SAF) package where the contents file references any system files (using relative traversal sequences) which are readable by the Tomcat user. If such a package is imported, this will result in sensitive content disclose, including retrieving arbitrary files or configurations from the server where DSpace is running.

The Simple Archive Format (SAF) importer / Batch Import (Zip) is only usable by site administrators (from user interface / REST API) or system administrators (from command-line). Therefore, to exploit this vulnerability, the malicious payload would have to be provided by an attacker and trusted by an administrator (who would trigger the import).

  • The most severe practical impact is a case where an attacker obtains DSpace administrator credentials and uses the Batch Import feature with a malicious SAF archive to expose sensitive local files readable by the Tomcat user.
  • An attacker without administrative credentials might use some other tactic to convince an administrator to import a malicious SAF archive they have supplied.

References

  • github.com/DSpace/DSpace
  • github.com/DSpace/DSpace/pull/11036
  • github.com/DSpace/DSpace/pull/11036.patch
  • github.com/DSpace/DSpace/pull/11037
  • github.com/DSpace/DSpace/pull/11037.patch
  • github.com/DSpace/DSpace/pull/11038
  • github.com/DSpace/DSpace/pull/11038.patch
  • github.com/DSpace/DSpace/security/advisories/GHSA-vhvx-8xgc-99wf
  • github.com/advisories/GHSA-vhvx-8xgc-99wf
  • nvd.nist.gov/vuln/detail/CVE-2025-53622

Code Behaviors & Features

Detect and mitigate CVE-2025-53622 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 7.6.4, all versions starting from 8.0 before 8.2, all versions starting from 9.0 before 9.1

Fixed versions

  • 7.6.4
  • 8.2
  • 9.1

Solution

Upgrade to versions 7.6.4, 8.2, 9.1 or above.

Impact 5.2 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:L

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

maven/org.dspace/dspace-api/CVE-2025-53622.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.