CVE-2026-42509: Apache Wicket has a Cross-site Scripting issue
(updated )
Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
References
Code Behaviors & Features
Detect and mitigate CVE-2026-42509 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →