Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.tomcat/tomcat
  4. ›
  5. CVE-2026-55956

CVE-2026-55956: Apache Tomcat has an Improper Authorization vulnerability

June 29, 2026 (updated November 4, 2026)

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

References

  • github.com/advisories/GHSA-5v3h-fjv2-54fg
  • github.com/apache/tomcat/commit/3f6bd2ba5e53d1f340bbe5ad2d42a28b29440b7a
  • github.com/apache/tomcat/commit/9c3b1efb74fd04f77639720af1d48a8f664ad9bb
  • github.com/apache/tomcat/commit/a0374c450970760efafbd8806a1db278830ba7bd
  • lists.apache.org/thread/dcjdcnnnww9hhdm016hr0l7hpw1bzjfp
  • nvd.nist.gov/vuln/detail/CVE-2026-55956
  • tomcat.apache.org/security-10.html
  • tomcat.apache.org/security-11.html
  • tomcat.apache.org/security-9.html

Code Behaviors & Features

Detect and mitigate CVE-2026-55956 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 7.0.109, all versions starting from 8.5.0 up to 8.5.100, all versions starting from 9.0.0-M.1 before 9.0.119, all versions starting from 10.1.0-M1 before 10.1.56, all versions starting from 11.0.0-M1 before 11.0.23

Fixed versions

  • 9.0.119
  • 10.1.56
  • 11.0.23

Solution

Upgrade to versions 9.0.119, 10.1.56, 11.0.23 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-285: Improper Authorization

Source file

maven/org.apache.tomcat/tomcat/CVE-2026-55956.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.