CVE-2026-65637: Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
(updated )
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.
Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.
References
- github.com/advisories/GHSA-f525-44xv-f2qj
- github.com/apache/tomcat/commit/40012414df828a56126f76a7339669c7c919aae7
- github.com/apache/tomcat/commit/8639b20f045c88f356b887204f52e897399f0de7
- github.com/apache/tomcat/commit/b823e88da077f5fa973e34d72359bded9f621e3c
- github.com/apache/tomcat/releases/tag/10.1.58
- github.com/apache/tomcat/releases/tag/11.0.25
- github.com/apache/tomcat/releases/tag/9.0.121
- lists.apache.org/thread/djog953z1ohsyt25bdvhfzbmsy22vgcj
- nvd.nist.gov/vuln/detail/CVE-2026-65637
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
Code Behaviors & Features
Detect and mitigate CVE-2026-65637 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →