CVE-2025-53506: Apache Tomcat Coyote vulnerable to Denial of Service via excessive HTTP/2 streams
(updated )
Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100.
Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.
References
- github.com/advisories/GHSA-25xr-qj8w-c4vf
- github.com/apache/tomcat
- github.com/apache/tomcat/commit/2aa6261276ebe50b99276953591e3a2be7898bdb
- github.com/apache/tomcat/commit/434772930f362145516dd60681134e7f0cf8115b
- github.com/apache/tomcat/commit/be8f330f83ceddaf3baeed57522e571572b6b99b
- lists.apache.org/thread/p09775q0rd185m6zz98krg0fp45j8kr0
- lists.debian.org/debian-lts-announce/2025/07/msg00009.html
- nvd.nist.gov/vuln/detail/CVE-2025-53506
Code Behaviors & Features
Detect and mitigate CVE-2025-53506 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →