CVE-2026-65182: Apache Tomcat has an Improper Access Control, Incorrect Authorization vulnerability
(updated )
Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.
References
- github.com/advisories/GHSA-gcx9-497g-6cp6
- github.com/apache/tomcat/commit/8bafd79a3b54684e80e9cb1bafd4746aede7d3f5
- github.com/apache/tomcat/commit/b2c56ec8f20c66773a1a813034ffcdb60841f1cf
- github.com/apache/tomcat/commit/b79752d2a8578d94743e2a95c50af297f780c0df
- lists.apache.org/thread/joosxvzc9b49ttj8lj0jw9mqt0ml767m
- nvd.nist.gov/vuln/detail/CVE-2026-65182
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
Code Behaviors & Features
Detect and mitigate CVE-2026-65182 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →