Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.tomcat/tomcat-catalina
  4. ›
  5. CVE-2026-55955

CVE-2026-55955: Improper Authentication

June 29, 2026 (updated July 10, 2026)

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.

Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

References

  • lists.apache.org/thread/g4p5sf45p3f9r011pwqs9r54yd64s106
  • nvd.nist.gov/vuln/detail/CVE-2026-55955

Code Behaviors & Features

Detect and mitigate CVE-2026-55955 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.0.13 before 9.0.119, all versions starting from 10.1.0-M1 before 10.1.56, all versions starting from 11.0.0-M1 before 11.0.23

Fixed versions

  • 9.0.119
  • 10.1.56
  • 11.0.23

Solution

Upgrade to versions 9.0.119, 10.1.56, 11.0.23 or above.

Weakness

  • CWE-287: Improper Authentication

Source file

maven/org.apache.tomcat/tomcat-catalina/CVE-2026-55955.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.