CVE-2025-55668: Apache Tomcat Session Fixation vulnerability
(updated )
Session Fixation vulnerability in Apache Tomcat via rewrite valve.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
References
- github.com/advisories/GHSA-23hv-mwm6-g8jf
- github.com/apache/tomcat/commit/8621e4c6ba2c916a41eb34cb0f781171ead33fb6
- github.com/apache/tomcat/commit/90306d971bb8b8393336d893644124fb2ca11d21
- github.com/apache/tomcat/commit/9c3673ba04009377cb0c81ccb6cf5078aec1aa95
- lists.apache.org/thread/v6bknr96rl7l1qxkl1c03v0qdvbbqs47
- nvd.nist.gov/vuln/detail/CVE-2025-55668
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
Code Behaviors & Features
Detect and mitigate CVE-2025-55668 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →