CVE-2025-46701: Apache Tomcat - CGI security constraint bypass
(updated )
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat’s GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.
References
- github.com/advisories/GHSA-h2fw-rfh5-95r3
- github.com/apache/tomcat
- github.com/apache/tomcat/commit/0f01966eb60015d975525019e12a087f05ebf01a
- github.com/apache/tomcat/commit/238d2aa54b99f91d1111467e2237d2244c64e558
- github.com/apache/tomcat/commit/2c6800111e7d8d8d5403c07978ea9bff3db5a5a5
- github.com/apache/tomcat/commit/8cb95ff03221067c511b3fa66d4f745bc4b0a605
- github.com/apache/tomcat/commit/8df00018a252baa9497615d6420fb6c10466fa74
- github.com/apache/tomcat/commit/fab7247d2f0e3a29d5daef565f829f383e10e5e2
- lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30j
- lists.debian.org/debian-lts-announce/2025/07/msg00009.html
- nvd.nist.gov/vuln/detail/CVE-2025-46701
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
Code Behaviors & Features
Detect and mitigate CVE-2025-46701 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →