CVE-2026-55957: Apache Tomcat has a Missing Critical Step in Authentication vulnerability
(updated )
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without providing the correct password.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
References
- github.com/advisories/GHSA-7895-gffq-w6jq
- github.com/apache/tomcat/commit/0cd21c0393b8811af22daddbba7b4e7328e2d79e
- github.com/apache/tomcat/commit/c32bbd37ea9ee0aaab848af4ee1c9a76e84240ea
- github.com/apache/tomcat/commit/fd96ab415631eea44636c94f911dd38427070ef9
- lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh
- nvd.nist.gov/vuln/detail/CVE-2026-55957
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
Code Behaviors & Features
Detect and mitigate CVE-2026-55957 with GitLab Dependency Scanning
Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →