Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.tomcat.embed/tomcat-embed-core
  4. ›
  5. CVE-2026-24734

CVE-2026-24734: Apache Tomcat has an Improper Input Validation vulnerability

February 17, 2026 (updated November 4, 2026)

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.

When using an OCSP responder, Tomcat Native (and Tomcat’s FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.

This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.

The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.

Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.

Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

References

  • access.redhat.com/errata/RHSA-2026:19054
  • access.redhat.com/errata/RHSA-2026:26323
  • access.redhat.com/errata/RHSA-2026:36790
  • access.redhat.com/errata/RHSA-2026:5611
  • access.redhat.com/errata/RHSA-2026:5612
  • access.redhat.com/errata/RHSA-2026:6569
  • access.redhat.com/errata/RHSA-2026:8334
  • access.redhat.com/security/cve/CVE-2026-24734
  • bugzilla.redhat.com/show_bug.cgi?id=2440426
  • github.com/advisories/GHSA-mgp5-rv84-w37q
  • github.com/apache/tomcat-native/commit/69a977dd427ad2a6da0f10aca3872386ee27f681
  • github.com/apache/tomcat/commit/e76e9eaa246f30debd603726d9147a8a8cb5171c
  • lists.apache.org/thread/292dlmx3fz1888v6v16221kpozq56gml
  • nvd.nist.gov/vuln/detail/CVE-2026-24734
  • security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-24734.json

Code Behaviors & Features

Detect and mitigate CVE-2026-24734 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.0.83 before 9.0.115, all versions starting from 10.1.0-M7 before 10.1.52, all versions starting from 11.0.0-M1 before 11.0.18

Fixed versions

  • 9.0.115
  • 10.1.52
  • 11.0.18

Solution

Upgrade to versions 9.0.115, 10.1.52, 11.0.18 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-295: Improper Certificate Validation

Source file

maven/org.apache.tomcat.embed/tomcat-embed-core/CVE-2026-24734.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.