Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.tomcat.embed/tomcat-embed-core
  4. ›
  5. CVE-2025-31651

CVE-2025-31651: Apache Tomcat Rewrite rule bypass

April 28, 2025 (updated November 3, 2025)

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible for a specially crafted request to bypass some rewrite rules. If those rewrite rules effectively enforced security constraints, those constraints could be bypassed.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.

Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6, which fix the issue.

References

  • github.com/advisories/GHSA-ff77-26x5-69cr
  • github.com/apache/tomcat
  • github.com/apache/tomcat/commit/066bf6b6a15a4e7e0941d4acf096841165b97098
  • github.com/apache/tomcat/commit/175dc75fc428930034a6c93fb52f830d955d8e64
  • github.com/apache/tomcat/commit/ee3ab548e92345eca0cbd1f01649eb36c6f29454
  • github.com/apache/tomcat/commit/fbecc915a10c5a3d634c5e2c6ced4ff479ce9953
  • lists.apache.org/list.html?announce@tomcat.apache.org
  • lists.debian.org/debian-lts-announce/2025/07/msg00009.html
  • nvd.nist.gov/vuln/detail/CVE-2025-31651
  • tomcat.apache.org/security-10.html
  • tomcat.apache.org/security-11.html
  • tomcat.apache.org/security-9.html

Code Behaviors & Features

Detect and mitigate CVE-2025-31651 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.5.0 up to 8.5.100, all versions starting from 9.0.76 before 9.0.104, all versions starting from 10.1.10 before 10.1.40, all versions starting from 11.0.0-M2 before 11.0.6

Fixed versions

  • 9.0.104
  • 10.1.40
  • 11.0.6

Solution

Upgrade to versions 10.1.40, 11.0.6, 9.0.104 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-116: Improper Encoding or Escaping of Output
  • CWE-150: Improper Neutralization of Escape, Meta, or Control Sequences

Source file

maven/org.apache.tomcat.embed/tomcat-embed-core/CVE-2025-31651.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.