Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.tomcat.embed/tomcat-embed-core
  4. ›
  5. CVE-2024-24549

CVE-2024-24549: Apache Tomcat Denial of Service due to improper input validation vulnerability for HTTP/2 requests

March 13, 2024 (updated October 29, 2025)

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98.

Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

References

  • github.com/advisories/GHSA-7w75-32cg-r6g2
  • github.com/apache/tomcat
  • github.com/apache/tomcat/commit/0cac540a882220231ba7a82330483cbd5f6b1f96
  • github.com/apache/tomcat/commit/810f49d5ff6d64b704af85d5b8d0aab9ec3c83f5
  • github.com/apache/tomcat/commit/8e03be9f2698f2da9027d40b9e9c0c9429b74dc0
  • github.com/apache/tomcat/commit/d07c82194edb69d99b438828fe2cbfadbb207843
  • lists.apache.org/thread/4c50rmomhbbsdgfjsgwlb51xdwfjdcvg
  • lists.debian.org/debian-lts-announce/2024/04/msg00001.html
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/3UWIS5MMGYDZBLJYT674ZI5AWFHDZ46B
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/736G4GPZWS2DSQO5WKXO3G6OMZKFEK55
  • nvd.nist.gov/vuln/detail/CVE-2024-24549
  • security.netapp.com/advisory/ntap-20240402-0002

Code Behaviors & Features

Detect and mitigate CVE-2024-24549 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 8.5.0 before 8.5.99, all versions starting from 9.0.0-M1 before 9.0.86, all versions starting from 10.1.0-M1 before 10.1.19, all versions starting from 11.0.0-M1 before 11.0.0-M17

Fixed versions

  • 8.5.99
  • 9.0.86
  • 10.1.19
  • 11.0.0-M17

Solution

Upgrade to versions 10.1.19, 11.0.0-M17, 8.5.99, 9.0.86 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.apache.tomcat.embed/tomcat-embed-core/CVE-2024-24549.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:16 +0000.