Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.struts/struts2-core
  4. ›
  5. CVE-2016-4003

CVE-2016-4003: Cross-site Scripting

April 12, 2016 (updated November 23, 2018)

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE, as used in Apache Struts, when using a single byte page encoding, allows remote attackers to inject arbitrary web script or HTML via multi-byte characters in an url-encoded parameter.

References

  • struts.apache.org/docs/s2-028.html
  • www.securityfocus.com/bid/86311
  • www.securitytracker.com/id/1035268
  • issues.apache.org/jira/browse/WW-4507
  • nvd.nist.gov/vuln/detail/CVE-2016-4003

Code Behaviors & Features

Detect and mitigate CVE-2016-4003 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 up to 2.3.24.1

Fixed versions

  • 2.3.24.3

Solution

Upgrade to version 2.3.24.3 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.apache.struts/struts2-core/CVE-2016-4003.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:46 +0000.