Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.solr/solr-core
  4. ›
  5. CVE-2017-7660

CVE-2017-7660: Security Vulnerability in secure inter-node communication

July 7, 2017 (updated November 28, 2018)

This package uses a PKI based mechanism to secure inter-node communication when security is enabled. It is possible to create a specially crafted node name that does not exist as part of the cluster and point it to a malicious node. This can trick the nodes in cluster to believe that the malicious node is a member of the cluster. So, if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin or if the user has implemented a custom Authentication plugin, which does not implement either HttpClientInterceptorPlugin or HttpClientBuilderPlugin, his/her servers are vulnerable to this attack. Users who only use SSL without basic authentication or those who use Kerberos are not affected.

References

  • cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7660

Code Behaviors & Features

Detect and mitigate CVE-2017-7660 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.3.0 up to 5.5.4, all versions starting from 6.0.0 up to 6.5.1

Fixed versions

  • 5.5.5
  • 6.6.0

Solution

Upgrade to versions 5.5.5, 6.6.0 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

maven/org.apache.solr/solr-core/CVE-2017-7660.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:22 +0000.