Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.shenyu/shenyu-admin
  4. ›
  5. CVE-2022-37435

CVE-2022-37435: Improper Privilege Management

September 1, 2022 (updated August 2, 2023)

Apache ShenYu Admin has insecure permissions, which may allow low-privilege administrators to modify high-privilege administrator’s passwords. This issue affects Apache ShenYu 2.4.2 and 2.4.3.

References

  • lists.apache.org/thread/ndblyxr2fdrvjtgbs1bogxgv2cgk7t28
  • nvd.nist.gov/vuln/detail/CVE-2022-37435

Code Behaviors & Features

Detect and mitigate CVE-2022-37435 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.4.2 up to 2.4.3

Fixed versions

  • 2.5.0

Solution

Upgrade to version 2.5.0 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-732: Incorrect Permission Assignment for Critical Resource

Source file

maven/org.apache.shenyu/shenyu-admin/CVE-2022-37435.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:04 +0000.