Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.ranger/ranger
  4. ›
  5. CVE-2015-0265

CVE-2015-0265: Apache Ranger Cross-site Scripting vulnerability

May 17, 2022 (updated April 14, 2025)

Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.

References

  • cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger
  • github.com/advisories/GHSA-83m2-9g78-rrj4
  • github.com/apache/ranger
  • mail-archives.apache.org/mod_mbox/ranger-dev/201508.mbox/%3CD1E7EC30.9D53F%25vel@apache.org%3E
  • nvd.nist.gov/vuln/detail/CVE-2015-0265
  • web.archive.org/web/20200228073946/http://www.securityfocus.com/bid/76208

Code Behaviors & Features

Detect and mitigate CVE-2015-0265 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.5.0

Fixed versions

  • 0.5.0

Solution

Upgrade to version 0.5.0 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.apache.ranger/ranger/CVE-2015-0265.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:34 +0000.