Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.ranger/ranger-plugins-common
  4. ›
  5. CVE-2025-59059

CVE-2025-59059: Apache Ranger has a Code Injection vulnerability

March 3, 2026 (updated March 4, 2026)

Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0.

Users are recommended to upgrade to version 2.8.0, which fixes this issue.

References

  • github.com/advisories/GHSA-c87w-642h-m97h
  • github.com/apache/ranger
  • lists.apache.org/thread/z47q86rho80390lf2qcmoc2josvs0gtv
  • nvd.nist.gov/vuln/detail/CVE-2025-59059

Code Behaviors & Features

Detect and mitigate CVE-2025-59059 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.8.0

Fixed versions

  • 2.8.0

Solution

Upgrade to version 2.8.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

maven/org.apache.ranger/ranger-plugins-common/CVE-2025-59059.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:28 +0000.