Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.ranger/ranger-nifi-registry-plugin
  4. ›
  5. CVE-2025-59060

CVE-2025-59060: Apache Ranger Vulnerable to Improper Validation of Certificate with Host Mismatch

March 3, 2026 (updated March 4, 2026)

Hostname verification bypass issue in Apache Ranger NiFiRegistryClient/NiFiClient is reported in Apache Ranger versions <= 2.7.0.

Users are recommended to upgrade to version 2.8.0, which fixes this issue.

References

  • github.com/advisories/GHSA-5fvg-qwcp-r325
  • github.com/apache/ranger
  • lists.apache.org/thread/c4plx81z3xs86vgl3fd95y3q7hhtff05
  • nvd.nist.gov/vuln/detail/CVE-2025-59060

Code Behaviors & Features

Detect and mitigate CVE-2025-59060 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.8.0

Fixed versions

  • 2.8.0

Solution

Upgrade to version 2.8.0 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-297: Improper Validation of Certificate with Host Mismatch

Source file

maven/org.apache.ranger/ranger-nifi-registry-plugin/CVE-2025-59060.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:19 +0000.