Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.qpid/qpid-broker-plugins-amqp-1-0-protocol
  4. ›
  5. CVE-2016-4432

CVE-2016-4432: Improper Authentication

October 16, 2018 (updated September 16, 2021)

The AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication and consequently perform actions via vectors related to connection state logging.

References

  • github.com/advisories/GHSA-q66c-h853-gqw2
  • nvd.nist.gov/vuln/detail/CVE-2016-4432

Code Behaviors & Features

Detect and mitigate CVE-2016-4432 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 6.0.3

Fixed versions

  • 6.0.3

Solution

Upgrade to version 6.0.3 or above.

Impact 9.1 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

maven/org.apache.qpid/qpid-broker-plugins-amqp-1-0-protocol/CVE-2016-4432.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:38 +0000.