Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.qpid/apache-qpid-broker-j
  4. ›
  5. CVE-2018-8030

CVE-2018-8030: Improper Input Validation

October 16, 2018 (updated September 3, 2021)

A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 7.0.0-7.0.4 when AMQP protocols 0-8, 0-9 or 0-91 are used to publish messages with size greater than allowed maximum message size limit (100MB by default). The broker crashes due to the defect. AMQP protocols 0-10 and 1.0 are not affected.

References

  • github.com/advisories/GHSA-7xr3-rgwh-pw22
  • nvd.nist.gov/vuln/detail/CVE-2018-8030

Code Behaviors & Features

Detect and mitigate CVE-2018-8030 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.0.0 before 7.0.5

Fixed versions

  • 7.0.5

Solution

Upgrade to version 7.0.5 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

maven/org.apache.qpid/apache-qpid-broker-j/CVE-2018-8030.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:24 +0000.