Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.portals.jetspeed-2/jetspeed-commons
  4. ›
  5. CVE-2016-0711

CVE-2016-0711: Apache Jetspeed vulnerable to Cross-site Scripting

May 17, 2022 (updated April 14, 2025)

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jetspeed before 2.3.1 allow remote attackers to inject arbitrary web script or HTML via the title parameter when adding a (1) link, (2) page, or (3) folder resource.

References

  • github.com/advisories/GHSA-5pgm-9g57-3wc7
  • mail-archives.apache.org/mod_mbox/portals-jetspeed-user/201603.mbox/%3C73AC0763-D44B-4BDF-867C-05AD4674A62F%40bluesunrise.com%3E
  • mail-archives.apache.org/mod_mbox/portals-jetspeed-user/201603.mbox/%3C73AC0763-D44B-4BDF-867C-05AD4674A62F@bluesunrise.com%3E
  • nvd.nist.gov/vuln/detail/CVE-2016-0711
  • portals.apache.org/jetspeed-2/security-reports.html

Code Behaviors & Features

Detect and mitigate CVE-2016-0711 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.1

Fixed versions

  • 2.3.1

Solution

Upgrade to version 2.3.1 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.apache.portals.jetspeed-2/jetspeed-commons/CVE-2016-0711.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.