Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.poi/poi
  4. ›
  5. CVE-2014-3574

CVE-2014-3574: Improper Input Validation in Apache POI

May 17, 2022 (updated August 16, 2022)

Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.

References

  • poi.apache.org/changes.html
  • rhn.redhat.com/errata/RHSA-2014-1370.html
  • rhn.redhat.com/errata/RHSA-2014-1398.html
  • rhn.redhat.com/errata/RHSA-2014-1399.html
  • rhn.redhat.com/errata/RHSA-2014-1400.html
  • www-01.ibm.com/support/docview.wss?uid=swg21996759
  • www.apache.org/dist/poi/release/RELEASE-NOTES.txt
  • exchange.xforce.ibmcloud.com/vulnerabilities/95768
  • github.com/advisories/GHSA-5wfp-8643-c58x
  • lucene.apache.org/solr/solrnews.html
  • nvd.nist.gov/vuln/detail/CVE-2014-3574

Code Behaviors & Features

Detect and mitigate CVE-2014-3574 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.10.1, version 3.11-beta1

Fixed versions

  • 3.10.1
  • 3.11-beta2

Solution

Upgrade to versions 3.10.1, 3.11-beta2 or above. *Note*: 3.11-beta2 may be an unstable version. Use caution.

Impact 4.3 MEDIUM

AV:N/AC:M/Au:N/C:N/I:N/A:P

Learn more about CVSS

Source file

maven/org.apache.poi/poi/CVE-2014-3574.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:27 +0000.