Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.openmeetings/openmeetings-parent
  4. ›
  5. CVE-2016-3089

CVE-2016-3089: Cross-site Scripting

August 19, 2016 (updated October 9, 2018)

Cross-site scripting (XSS) vulnerability in the SWF panel in Apache OpenMeetings allows remote attackers to inject arbitrary web script or HTML via the swf parameter.

References

  • openmeetings.apache.org/security.html
  • nvd.nist.gov/vuln/detail/CVE-2016-3089

Code Behaviors & Features

Detect and mitigate CVE-2016-3089 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 3.1.1

Fixed versions

  • 3.1.2

Solution

Upgrade to version 3.1.2 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

maven/org.apache.openmeetings/openmeetings-parent/CVE-2016-3089.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.