Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.nifi/nifi
  4. ›
  5. CVE-2017-5636

CVE-2017-5636: Injection Vulnerability

October 19, 2017 (updated November 7, 2017)

The proxy chain serialization/deserialization is vulnerable to an injection attack where a carefully crafted username could impersonate another user and gain their permissions on a replicated request to another node.

References

  • www.securityfocus.com/bid/96731
  • nifi.apache.org/security.html
  • nvd.nist.gov/vuln/detail/CVE-2017-5636

Code Behaviors & Features

Detect and mitigate CVE-2017-5636 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.7.0 up to 0.7.1, all versions starting from 1.1.0 up to 1.1.1

Fixed versions

  • 0.7.2
  • 1.1.2

Solution

Upgrade to versions 0.7.2, 1.1.2 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

maven/org.apache.nifi/nifi/CVE-2017-5636.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.