Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.linkis/linkis-datasource
  4. ›
  5. CVE-2023-29216

CVE-2023-29216: Apache Linkis DatasourceManager module has deserialization vulnerability

April 10, 2023 (updated February 13, 2025)

In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker can use the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Users should upgrade their version of Linkis to version 1.3.2.

References

  • github.com/advisories/GHSA-rrhf-32rq-f28h
  • github.com/apache/linkis
  • linkis.apache.org/download/release-notes-1.3.2
  • lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l
  • nvd.nist.gov/vuln/detail/CVE-2023-29216

Code Behaviors & Features

Detect and mitigate CVE-2023-29216 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.2

Fixed versions

  • 1.3.2

Solution

Upgrade to version 1.3.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-502: Deserialization of Untrusted Data

Source file

maven/org.apache.linkis/linkis-datasource/CVE-2023-29216.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.