Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.kylin/kylin
  4. ›
  5. CVE-2021-45457

CVE-2021-45457: Insufficiently Protected Credentials

January 6, 2022 (updated July 12, 2022)

In Apache Kylin, Cross-origin requests with credentials are allowed to be sent from any origin. This issue affects Apache Kylin 2 and prior versions; Apache Kylin 3 and prior versions; Apache Kylin 4 and prior versions.

References

  • www.openwall.com/lists/oss-security/2022/01/06/2
  • lists.apache.org/thread/rzv4mq58okwj1n88lry82ol2wwm57q1m
  • nvd.nist.gov/vuln/detail/CVE-2021-45457

Code Behaviors & Features

Detect and mitigate CVE-2021-45457 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 up to 2.6.6, all versions starting from 3.0.0 before 3.1.3, version 4.0.0

Fixed versions

  • 3.1.3
  • 4.0.1

Solution

Upgrade to versions 3.1.3, 4.0.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

maven/org.apache.kylin/kylin/CVE-2021-45457.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:00 +0000.