Advisory Database
  • Advisories
  • Dependency Scanning
  1. maven
  2. ›
  3. org.apache.kerby/kerby-asn1
  4. ›
  5. CVE-2026-57914

CVE-2026-57914: Apache Kerby vulnerable to denial of service

June 26, 2026 (updated November 3, 2026)

By sending a deeply nested ASN1 structure to a Apache Kerby client or service, it’s possible to trigger a StackOverFlow Exception which can lead to denial of service issues. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

References

  • github.com/advisories/GHSA-x6vc-x4v4-hjhr
  • github.com/apache/directory-kerby/commit/0bcd73eb9eb54622b84539b5fc23066057c6b5e8
  • github.com/apache/directory-kerby/releases/tag/kerby-all-2.1.2
  • lists.apache.org/thread/w98h2q8wz0bq97vhz4vf55hqomcb2j1m
  • nvd.nist.gov/vuln/detail/CVE-2026-57914

Code Behaviors & Features

Detect and mitigate CVE-2026-57914 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.2

Fixed versions

  • 2.1.2

Solution

Upgrade to version 2.1.2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

maven/org.apache.kerby/kerby-asn1/CVE-2026-57914.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:00 +0000.